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SMART Notebook publisher is an Adobe® InDesign® plug-in that enables you to export InDesign
files in .notebook file format. You can use InDesign to create compelling content, tag elements of the
content for certain types of interactivity, and then export the document as a SMART Notebook file.
You can then open the file in SMART Notebook collaborative learning software to add more
interactive elements to your document or present your material on a SMART Board™ interactive
whiteboard.

The following outlines some feature of SMART Notebook publisher.

Creating new documents
You can use Adobe InDesign to create new documents optimized for SMART Notebook software.

Rendering images and text as vector or raster
You can export image objects and text objects from InDesign in either vector or raster format.

Exporting to SMART Notebook software
You can export your document to SMART Notebook software with a single click of a button.
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Locking content
You can lock or protect objects you create in InDesign so that they can’t be moved, rotated or edited
after you export them to SMART Notebook software.

Adding interactive features
You can add interactive features to your objects, including links to websites, other document pages or
sound files, as well as animations, Infinite Cloner and Erase to Reveal.

Showing or hiding tags
You can show tags in InDesign to help you identify an object’s export format and interactive features.
You can hide the tags if they obstruct your objects while you’re working on your InDesign page.
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Installing SMART Notebook
publisher

CompUter FeqUIrEMENTS . 4
Requirements for Adobe InDesign CS4. ... 4
Windows operating systems. ... il 4

Mac operating system software. .. ... . 4
Requirements for Adobe InDesign CS5, ... .. 4
Windows operating systems. ... 4

Mac operating system software. ... ... 4
Installing on Windows operating SyStems. . .. ... .. i 5
Installing on Mac operating system software ... ... 5

Before you install SMART Notebook publisher, ensure that SMART Notebook software is installed
on your computer. You can download SMART Notebook publisher by going to SMART Notebook
Ecosystem Network login page, and then follow the on-screen instructions. If you don’t have a
product key, request a SMART Notebookdeveloper license from http://sen.smarttech.com/Service-
requests/9-Notebook-software-license.aspx .

Follow these installation instructions for either Windows® operating systems or Mac operating
systems software.
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SMART Notebook publisher works with Adobe InDesign CS4 and CS5 on both Windows operating
systems and Mac operating system software.

Requirements for Adobe InDesign CS4
Windows operating systems

e Adobe InDesign CS4

e 20 MB of free hard disk space

e Windows XP SP3, Windows Vista® or Windows 7 operating system
Mac operating system software

e Adobe InDesign CS4

e 20 MB of free hard disk space

e Mac OS X operating system software 10.5.7 or 10.6.x

Requirements for Adobe InDesign CS5
Windows operating systems
¢ Adobe InDesign CS5
e 10 MB of free hard disk space
e Windows XP SP3, Windows Vista or Windows 7 operating system
¢ Adobe Extension Manager 5.0.298 or later
Mac operating system software
e Adobe InDesign CS5
e 10 MB of free hard disk space

¢ Intel® Multicore processor

Mac OS X operating system software 10.5.7 or 10.6.x

Adobe Extension Manager 5.0.298 or later



CHAPTER 2
Installing SMART Notebook publisher

To install SMART Notebook Publisher for Adobe InDesign CS4

1. Gotothe SMART Ecosystem Network login page, and then follow the on-screen instructions
to download the file to your desktop.

2. Double-click the .exe file.
The SMART Notebook Publisher wizard appears.

3. Follow the on-screen instructions to complete the installation.

To install SMART Notebook Publisher for Adobe InDesign CS5

1. Gotothe SMART Ecosystem Network login page, and then follow the on-screen instructions
to download the file to your desktop.

2. Double-click the .zxp file.
The Adobe Extension Manager appears.

3. Follow the on-screen instructions to complete the installation.

To install SMART Notebook Publisher for Adobe InDesign CS4

1. Gotothe SMART Ecosystem Network login page, and then follow the on-screen instructions
to download the file to your desktop.

2. Double-click the file.
The file contents decompress.

3. Move thefile’s contents to Applications/Adobe InDesign/CS4/Plug-Ins.
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To install SMART Notebook Publisher for Adobe InDesign CS5

1. Gotothe SMART Ecosystem Network login page, and then follow the on-screen instructions
to download the file to your desktop.

2. Double-click the file.
The Adobe Extension Manager appears.

3. Follow the on-screen instructions.
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After you install the SMART Notebook publisher plug-in for Adobe InDesign, the SMART Notebook
item appears in the InDesign menu bar. SMART designed the menu items to look and behave like
other InDesign menu items. If you click Rendering Options, Locking or Add Interactivity, a dock
appears containing panels that you can dock, move and hide as you can with other InDesign panels.
Using these menu items and panels, you can create new documents, tag text for vector or raster
export, show or hide tags and export your document to a SMART Notebook file.
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When you create a new document, SMART Notebook publisher sets the document pages to
landscape orientation at 800 x 600 points so that all content on the pages is visible in a SMART
Notebook page without scrolling. This size is optimal for viewing on most SMART Board interactive
whiteboards.

To create a new document
1. Select SMART Notebook > File > New SMART Notebook Document.

The New SMART Notebook Document dialog box appears.

H NoOTES

o You can also create a new document by clicking File > New > SMART Notebook
Document.

o You can create a new document by clicking File > New > Document but it won't be
set to landscape orientation at 800 x 600 points. See Resizing to the SMART
Notebook page on page 17.

2. Type the number of pages you want in your document.

3. If you make your InDesign document available to users who haven't installed the SMART
Notebook publisher plug-in, select Enable missing plug in warning, and then click OK.

When you copy the InDesign file to a computer that doesn’t have the SMART Notebook
publisher plug-in installed, a Missing Plug-ins message appears.

IMPORTANT

You can’t enable or disable the Enable missing plug-in waming option after you create the
document.

A new blank document appears.

4. Click File > Save as, type a file name for your InDesign file, and then click Save.

B 1p

If you add background images to your document pages, lock or protect the images so that SMART
Notebook users can’t move or delete them. See Locking content on page 15 for more information.
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When you're finished your InDesign document, you can export the entire document, select pages or a
range of pages to a SMART Notebook file. You can also choose to automatically open the file in
SMART Notebook after you export it.

To export to a SMART Notebook file
1. Select SMART Notebook > File > Export.
The Export SMART Notebook Document dialog box appears.
2. Select the number of pages to export.

3. If you want to open the document in SMART Notebook software after you export it, select
Automatically open.

4. Click Export.
The Save As dialog box appears.
5. Type aname in the File Name area, and then click Save.

If you selected the option in step 3, SMART Notebook software appears showing the exported
document.

H NOTES

o You can also export your document by clicking File > Export for SMART Notebook
software.

o Your exported file can appear differently on other computers if they have a different
operating system, video resolution or screen size than your computer.
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By default, SMART Notebook publisher exports all text and image objects to SMART Notebook
software in raster format. By exporting objects in raster format, you preserve the “look and feel’of the
content when you see it on the SMART Notebook page; however, the SMART Notebook user won’t
be able to edit the content.

All objects that you tag as raster in InDesign export to SMART Notebook software as 144 dpi pixel-
based raster objects which is twice the 72 dpi resolution native to SMART Notebook software. You
can see the pixels that make up raster objects when you zoom in. Text objects aren’t recognized as
text, so you're unable to edit them using SMART Notebook software after you export them.

This is raster

You can also choose to export text orimage objects to SMART Notebook software in vector format.
Text that you render in vector format in InDesign exports to SMART Notebook software as vector
text objects. SMART Notebook software recognizes these fields as text so you can edit the text and
change attributes like font, color and size. You can export any font that’s installed on your computer
as vector.

One characteristic of vector text objects is that you can resize them without compromising quality.
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H NOTES
o The image quality of raster formatted objects or text reduces if you change their scale.

o Many of InDesign’s text formatting properties aren’t supported by SMART Notebook
software so they don’t appear in the vector-tagged text objects on the SMART Notebook

page.

o If you want to keep the original design intact and you don’t want users to edit the content in
SMART Notebook software, use raster formatting.

Tagging objects for export

By default, SMART Notebook publisher exports all objects in raster format, preserving the image and
text objects’ properties. If you want to allow SMART Notebook users to edit the objects you can
export them in vector format, but they can lose some of their properties. See Exported vector object
properties on page 14 and Exported vector text properties on next page for more information.

To tag objects for vector export
1. Select a text orimage object.
2. Ifthe dock isn't open, select SMART Notebook > Rendering Options.
3. Select Export as vector m

The vector tag m appears on the bottom-right corner of the object.

To tag objects for raster export
1. Select a text orimage object.
2. Ifthe dock isn’t open, select SMART Notebook > Rendering Options.

3. Select Export as raster.

The vector tag m clears from the object.

11
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Exported vector text properties

IMPORTANT

If you export text in vector format, it might not appear the same on a SMART Notebook page
because of the different formatting options available in SMART Notebook software, such as
character spacing, leading indents and bullet types.

You can export text in vector format using any font installed on your computer. Use common fonts
because you're unable to embed fonts in SMART Notebook software.

You can export text objects in vector format with the following formatting properties:

e Font size and color e Boald, italics and underline o Bullets
e Transparency o Left and right justification

The following are examples of effects and formatting that aren’t supported and are removed when you
export text objects in vector format. See Removing unsupported text features on next page to remove
these unsupported effects before you export the document.

e Kerning e Tracking e Case (e.g., small caps)
 Position o Strikethrough e Ligatures
e Scale + Baseline shift o Skew
¢ Indents and spacing o Underline o Color options
e Drop caps
H NoTES

o SMART recommends that you use text boxes without lines or fill.
o If you export bullets in vector format, they don’'t always behave as expected.
o Shaped objects containing text aren’t supported.

o Frames within frames aren’t supported.

12
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Removing unsupported text features
If your InDesign document has text effects or paragraph styles that aren’t supported in SMART

Notebook software, you can remove them and preview what the exported file looks like by using the
Removing unsupported text features option. See To remove unsupported text features on next page.

If you have a text object with a drop shadow, selecting the option tags the object for vector export
and removes the effect as shown below.

Raster text object with Unsupported text features Text object seen on
drop shadow effect removed SMART Notebook page
Ipsum lorem ataspit, Ipsum lorem ataspf, Ipsum lorem ataspit,
intium quos, recerro. = Sintium qUOS recerro | g sintium quos recerro
earum quatur? earum quatur? Export ~bearum quatur?

If InDesign has automatically inserted hyphens in a text object, selecting the option tags the object
for vector export and removes the hyphens as shown below.

Raster text object with Unsupported Text object seen on
auto-inserted hyphens hyphens removed SMART Notebook page
[psum lore- [psum [psum
mataspit, sin- —>  loremataspit, ;"‘pon loremataspit,
tium quose- sintium sintium
cerro? guosecerro? quosecerro?
H NoTES

o You can retain text effects by exporting the text object in raster format.

o If you tag atext object for vector export, but don’'t remove the unsupported text features, you
won't be able to preview the text in InDesign.

13
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To remove unsupported text features
1. Select the text object.
2. Ifthe dock isn’t open, select SMART Notebook > Rendering Options.
3. Select Remove unsupported text features.

The unsupported text features are removed, and the vector tag m appears on the bottom-right
corner of the object.

H nNoTE

Repeat the procedure if you add features to your text object after you initially perform this
procedure..

Exported vector object properties
SMART Notebook software interprets lines exported in vector format as digital ink and converts
shapes into shapes you can edit.

The following are examples of formatting that isn’t supported by SMART Notebook publisher when
you export objects in vector format.

Shapes with gradient fill

Text within objects
e Frames within frames

e Compound paths

If you export on a SMART Notebook page, they appear as
straight lines straight lines

curved or multi-point lines digital ink

closed objects closed shapes that you can fill

circles and ellipses polygon shapes

H NoTE

If you have compound paths in your document, click Object > Paths > Release Compound Path
on the InDesign menu bar to make them compatible with SMART Notebook software. You might
have to do this several times.

14
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When you create new content, text and image objects are unlocked by default.

H NoOTES

o When you lock an object, it'’s locked on a SMART Notebook page only. It isn’'t locked on your
InDesign page.

o After you export the document, SMART Notebook users can unlock objects, but they can’t
unprotect an object.

There are five options for locking objects:

Option Description

Unlock You can move, rotate and edit the object

Lock in place You can’t move, rotate or edit the object

Allow move You can move the object, but you can’t rotate or edit it
Allow move and rotate You can move or rotate the object, but you can’t edit it
Protect You can’t move, rotate, edit or unprotect the object
H NoTEs

o If users want to copy or paste objects in SMART Notebook software, they can unlock them.
They can’t remove protection from an object, so they can’t copy or paste protected objects.

o Protect content such as copyrighted images when you want to be sure that users can’'t
unlock it.

o SMART Notebook software puts protected content into the bottom layer of the SMART
Notebook page where users can’t unlock it.

To lock or protect objects
1. Select the text orimage object.

2. Select SMART Notebook > Object Attributes.

15



CHAPTER 3
Using SMART Notebook publisher

3. Select one of the options under the Locking heading.

A tag indicating the option you selected appears at the edge of the object. If you selected
Protect, the object also has a cross-hatch shading over it, as shown below.

-
-

H nNoTE

The Show/Hide Tags feature also removes the cross hatch shading from protected objects.
See Showing or hiding tags below.

Depending on whether you tag a single object or a grouped object, the Rendering, Locking or
Interactivity tags appear below or beside the object or objects.

Single object Grouped object
L~ Z b

(8§

If the tags obscure other objects on your page, you can hide them. To show them again, repeat the
procedure below.

B nNoTE

If you put InDesign into Overprint Preview mode, all SMART Notebook publisher tags are hidden.

16
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To show or hide tags

Select SMART Notebook > Show/Hide Tags, and then select or clear the option.

H nNoTE

If there’s a check mark beside the tag type in the menu, tags are showing.

When you create a new document using the procedure in Creating a new document on page 8,
SMART Notebook publisher sets the pages to landscape orientation at 800 x 600 points so that all
content on the pages is visible in a SMART Notebook page without scrolling.

If you import an InDesign file or create a new one (using File > New menu in InDesign) with different
dimensions or in portrait orientation, the exported file doesn’t fit the SMART Notebook page.

You can use the Resize to SMART Notebook Page feature to change your document’s orientation to
landscape and resize it to 800 x 600 points.

H NoOTES

o If your page is more than 800 points wide, content on the page is cropped from the SMART
Notebook page.

o If your page is more than 600 points long, the SMART Notebook page extends so that users
must use a scroll bar to see all of the page.

To resize your InDesign page
1. Select SMART Notebook > Document Setup > Resize to SMART Notebook Page.

A SMART Notebook publisher dialog box appears stating that the document will resize to 800
x 600 points, and that some objects could fall outside of the viewable area.

Select the Don’t show again option if you don’t want to see this dialog box again.

2. Click OK.

17
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You can add one or more interactive effects to the objects on your document pages. You can also
modify or remove all of these effects after you export your document to SMART Notebook software.

You can add hyperlinks to objects that link to another page in your document or to a web page. You
can also choose to use the object or an icon on the corner of the object to open the link.

To add a hyperlink
1. Select the text orimage object.
2. Ifthe dock isn't open, select SMART Notebook > Add Interactivity.
3. Select SMART Hyperlink .
4. Select a destination type from the Location drop-down list.

The Launch by clicking options appear.

19
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5. If you select Page in this file, select the page number from the drop-down list.
If you select Web page, type the URL in the text field.
A Page in this file |57 or Web page |", || tag appears at the edge of your InDesign object.

H nNoTE

A red tag on your InDesign object indicates that you didn’t select a page or the link is
missing.

6. If you want to add the hyperlink to the entire object, select Object in the Launch by clicking
area.

If you want to add the hyperlink to an icon on the lower-left corner of the object on the SMART
Notebook page, as shown below, select Corner icon.

@

H nNoTE

SMART Notebook users won’'t know that there’s a link on an object unless you tell them or
select Corner icon.

To remove a hyperlink
1. Select the object.
2. Ifthe dock isn’t open, select SMART Notebook > Add Interactivity.
3. Select SMART Hyperlink [5].

4. Select None from the Location drop-down list.

You can hide content with a rectangular color fill that you can later reveal by erasing in SMART
Notebook software. The Erase to Reveal feature hides the entire object, so if you want to hide a

portion of an object, or use an irregularly shaped mask to hide an object, see Altemative Erase to
Reveal on page 22.

20
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[ To enable Erase to Reveal

1. Select the text orimage object.
If the dock isn’t open, select SMART Notebook > Add Interactivity.
Select Erase To Reveal .

> oD

Select a color from the Ink color drop-down list.

B T

o The colors shown in the list are the same as the colors in the InDesign Swatch list.
o Use only solid colors. SMART Notebook publisher doesn’t support gradient fills.

o If you want the objects to be invisible until you reveal them, select the same color as
the page’s background color.

o If youwant it to be obvious that ink is covering an object, select a color that contrasts
the background color.

A green eraser tag appears below the object, and a small rectangle showing the selected color
appears on the lower-right corner of the object.

q

After you save and export the document to SMART Notebook software, a colored rectangular mask
hides the object. The rectangle is four points larger, with four point radius corners, than the object.
You can use the eraserin SMART Notebook software to erase the colored mask, revealing the

object.
'EXAMPLE
: ) ) SMART Notebook SMART Notebook
- InDesign object , . . .
object hidden object partially revealed

7

o - =

Export as Erase the
.notebook K
file mas
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You can create your own “Erase to Reveal” effect to hide a portion of an object or an irregularly
shaped object by creating your own masking shape.

To hide an object

1.

Draw a thick line with more than two points using InDesign drawing tools to create a shape
slightly larger than the object you want to hide.

Change the shape’s color as required.

B T

If you want the objects to be invisible until you reveal them, select the same color as the
page’s background.

Drag the shape over the object you want to hide.
Select the shape.

If the dock isn’t open, select SMART Notebook > Rendering Options.
Select Export as vector m

The vector tag m appears on the bottom-right corner of the object.

After you save and export the document to SMART Notebook software, a colored mask hides the
object. You can use the eraserin SMART Notebook software to erase the colored mask, revealing

the object.
Mask changed
InDesign object to white and SMART Mask partiall
i gn obl Notebook P y
with mask tagged for . erased
masked object
vector

22
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By enabling the Infinite Cloner, you can quickly duplicate text orimage objects after you export them
to SMART Notebook software.

NOTE

Don’t enable the Infinite Cloner on objects that have interactive effects such as animation or links.

To enable the Infinite Cloner

1.
2.

Select the text orimage object.

After you save and export the document to SMART Notebook software, you can drag the

SMART Notebook
object cloned

If the dock isn’t open, select SMART Notebook > Add Interactivity.
Select Infinite Clonerm.
Select the Infinite Cloner check box.
A green Infinite Clonertag appears below the object.
object to create copies.

) SMART

InDesign
. Notebook
object .
object

(6

—

Export as a
.notebook file

sl

-
-
-—

*

Drag
object

-

For more information on using the Infinite Cloner feature in SMART Notebook software, click the
SMART Board icon [*]in the Windows notification area or Mac dock, select Help and then search
for Infinite Cloner.
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You can add links from objects to MP3 sound effects files that open when you select the object. You
can also choose to use the object or an icon at the corner of the object to open the sound file.

NOTES

o The linked MP3 file isn’t packaged in the InDesign file, but it is embedded in the exported
SMART Notebook file.

o Large MP3 files can affect the performance of the SMART Notebook page.

To add a sound effect to an object

1.
2.

w

24

Select the text orimage object.
If the dock isn’t open, select SMART Notebook > Add Interactivity.
Select Sound Effect ).
Select the Add sound check box.
The File box and the Launch by clicking options appear, and a tag appears at the edge of
your InDesign object.
H NoTE

A red tag on your InDesign object indicates that you didn’t select a sound file or the link is
broken.

Click Browse and locate the MP3 sound file you want to link to the object.
If you want to link the MP3 file to the entire object, select Object in the Launch by clicking area.

If you want to link the MP3 file to a speaker icon on the lower-left corner of the object, as shown
below, select Corner icon.

J.

H NoTE

Users won't know that there is a sound effect on an object unless you tell them, or select
Corner icon.
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You can tag text orimage objects for animation in a variety of ways:
e Fadeinorout

Flip around axis

e Flyinorout

Shrink and grow

Spin

The options you can use to set the direction, speed, start and repetition vary depending on the
animation type you select.

IMPORTANT

You are unable to see or demonstrate the animation on your InDesign page. The animation is visible
only on your SMART Notebook page after you export it.

To animate an object
1. Select the text orimage object.
2. Ifthe dock isn’t open, select SMART Notebook > Add Interactivity.
3. Select Animation m
4. Select an option from the Type drop-down list.

A green tag appears at the edge of the object, as shown below.

-
-
=
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5. Select the characteristics of the animation from the Direction, Speed, Occurs and Repeats
drop-down lists.

H NoTE
The options available change depending on the animation type selected.

After you save and export the document to a SMART Notebook file, you can use SMART
Notebook software to change the animation properties .
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Chapter 5
Troubleshooting

Troubleshooting INDesign ISSUES. . . ..l
Troubleshooting eXport ISSUES. . ... il

This section includes information on how to troubleshoot common problems you could encounter
when using the SMART Notebook publisher plug-in for InDesign.
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CHAPTER 5

Troubleshooting

Issue

Cause

Solution

When you install the SMART
Notebook publisher plug-in for
InDesign CS5 for Windows
computers, a "cannot be
verified" error message appears.

A certificate authority issuer is
missing from the Certificate
manager Trusted Root
Certification Authorities
folder on the computer.

Follow the instructions on
/www.globalsign.com/support
[root-certificate/osroot.php to
download and install the
GlobalSign Root CA certificate.

When you undo changes to an
object’s sound, animation or
Erase to Reveal features while
the object is selected, the object
shows that the changes are
reversed, but the panels don’t
update to show the changes.

Clear and then select the object
to refresh the panel, showing
the changes

When you assign a gradient
color swatch, an error and a
white Erase to Reveal object
appears.

Notebook publisher software
doesn’t support gradient color.

When you use InDesign CS5 on
a Mac computer, the SMART
Notebook publisher panels
behave unexpectedly.

This is a known Adobe
InDesign issue.

When you stack the SMART
Notebook publisher panels and
select a lower one to bring to the
front, it behaves unexpectedly.

This is a known Adobe
InDesign issue.

Resize the panel to refresh it.

When you use InDesign CS5 on
a Mac computer, you must
select controls, such as Infinite
Cloner, twice to activate them.

This is a known Adobe
InDesign issue.
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CHAPTER 5

Troubleshooting

This section provides information to help you troubleshoot issues you encounter when exporting your
InDesign pages to SMART Notebook software.

Issue Cause Solution
The color of text exported in SMART Notebook publisher Use RGB colors when creating
vector format appears differently uses Adobe InDesign Color your InDesign document.
on a SMART Notebook page. Management System to
convert CMYK color to RGB

when it saves the file as a
.notebook file.

On Mac computers, object lines SMART Notebook software Use a line thickness greater
exported in vector format don't  doesn’t support a line thickness than one pixel when creating
appear on a SMART Notebook  of less than one pixel. your InDesign document.

page.

A sound file linked to an object ~ The InDesign Package feature  Copy the sound file to the same
on an InDesign page doesn’t doesn’t include the sound location on the computer with
play in SMART Notebook file. The sound file mustbeon ~ SMART Notebook software.

software on a different computer. the computer with SMART
Notebook software at the same
location as the computer with
InDesign.

Gradient fills, compound shapes SMART Notebook software Refer to

and special effects on objects doesn’'t support these InDesign  (smarttech.com/kb/158137).
exported in vector format don't  features

appear correctly on a SMART

Notebook page.

Objects and text rotated using SMART Notebook publisher
the InDesign Rotate Spread doesn’t support the Rotate
feature don’t appear correctly on  Spread feature.

a SMART Notebook page.
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