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Internet Blocking Feature Doesn’t Work in SynchronEyes Software 6.x

SMART Software SynchronEyes classroom management software 6.x
Operating Systems Windows operating systems

Issue

The Internet blocking feature doesn’t work.

Cause

The Internet blocking feature in SynchronEyes software 6.x doesn’t work:

  • with browsers other than Microsoft Internet Explorer, such as Netscape and Mozilla.

  • with Windows XP (SP2), if the appropriate .dll isn’t correctly registered and enabled.

Solution

To block Internet browsers other than Internet Explorer

The Internet blocking feature is designed for use with Microsoft Internet Explorer and won’t work with other browsers, such as Netscape and Mozilla. As an alternative, use application blocking to block students from accessing the Internet using other browsers.

  1. Click Applications in the Views toolbar or select View > Applications.

    The Applications view appears.

  2. Click New Rule or select Edit > New Rule.

    The New Application Blocking Rule dialogue box appears.

  3. Type the Block Rule Name.

  4. Select Block the following applications.

  5. Select the browser, for example, netscape.exe, from the List of Applications and click

    Add.

    If the browser isn’t included in the list of applications, click Browse, navigate to and select the application's executable file and click Open. Select it from the List of Applications and click Add.

  6. Click OK to close the New Application Blocking Rule dialogue box

    The new application block rule appears in the Applications Blocking Rules list.

  7. If you want to apply the block to all of your students, click the All Students tab.

    If you want to apply the block to a group, click the group’s tab.

    If you want to apply the block to selected students, select their names in the Student’s list.

  8. Select the application blocking rule and click Activate Rules or select Edit > Activate

    Rules.

  9. A message appears asking for confirmation. Click Block Applications.

If one of the selected students is running the restricted browser, the student’s browser closes automatically. If one of the selected students tries to open a restricted browser, the Application Blocked message appears, advising them that the application is blocked.

The Application Block symbol appears beside the selected students in the Student’s list and next to the activated rule in the Application Blocking Rule list.

To block Internet access on Windows XP (SP2)

The Internet blocking works with Windows XP (SP2), only if IEHelper SEyesIEBlock.dll is correctly registered and enabled.

  1. In Internet Explorer, select Tools > Manage Add-ons.

    The Manage Add-Ons dialogue box appears.

  2. If the IEHelper SEyesIEBlock.dll is disabled:

  3. Select IEHelper SEyesIEBlock.dll and click Enable.

    The Add-on Status message appears.

  4. Click OK.

  5. Click OK to close the Manage Add-Ons dialogue box.

    If this doesn’t resolve the issue, the .dll may not be registered properly. To register the .dll correctly, you must unregister it first.

  6. To unregister the .dll:

  7. Open a command prompt

  8. Type regsvr32 /u SEyesIEBlock.dll.

  9. Click OK.

  10. To register the .dll:

  11. Open a command prompt.

  12. Type regsvr32 SEyesIEBlock.dll.

  13. Click OK.

  14. If “regsvr32 not found” or “regsvr32 unknown command” appears, repeat step 5, but specify the entire path. The path is usually C:\windows\system32\regsvr32.

First Published 19 January 2006
Last Updated 9 November 2007

 
       
SMART Technologies is a leading provider of technology solutions that enable inspired collaboration in schools and workplaces around the world by turning group work into a highly interactive, engaging and productive experience. SMART delivers an integrated solution of hardware, software and services designed for superior performance and ease of use, and remains a world leader in interactive displays.
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