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About SMART Notebook™ publisher
SMART Notebook publisher is an Adobe® InDesign® plug-in that enables you to export InDesign
files in .notebook file format. You can use InDesign to create compelling content, tag elements of the
content for certain types of interactivity, and then export the document as a SMART Notebook file.
You can then open the file in SMART Notebook collaborative learning software to addmore
interactive elements to your document or present your material on a SMART Board™ interactive
whiteboard.

SMART Notebook publisher features
The following outlines some feature of SMART Notebook publisher.

Creating new documents
You can use Adobe InDesign to create new documents optimized for SMART Notebook software.

Rendering images and text as vector or raster
You can export image objects and text objects from InDesign in either vector or raster format.

Exporting to SMART Notebook software
You can export your document to SMART Notebook software with a single click of a button.
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Locking content
You can lock or protect objects you create in InDesign so that they can’t bemoved, rotated or edited
after you export them to SMART Notebook software.

Adding interactive features
You can add interactive features to your objects, including links to websites, other document pages or
sound files, as well as animations, Infinite Cloner and Erase to Reveal.

Showing or hiding tags
You can show tags in InDesign to help you identify an object’s export format and interactive features.
You can hide the tags if they obstruct your objects while you’re working on your InDesign page.

CHA PT ER 1

Getting started

2



Installing SMART Notebook
publisher
Computer requirements 4

Requirements for Adobe InDesign CS4 4
Windows operating systems 4
Mac operating system software 4

Requirements for Adobe InDesign CS5 4
Windows operating systems 4
Mac operating system software 4

Installing onWindows operating systems 5
Installing onMac operating system software 5

Before you install SMART Notebook publisher, ensure that SMART Notebook software is installed
on your computer. You can download SMART Notebook publisher by going to SMART Notebook
Ecosystem Network login page, and then follow the on-screen instructions. If you don’t have a
product key, request a SMART Notebookdeveloper license from http://sen.smarttech.com/Service-
requests/9-Notebook-software-license.aspx .

Follow these installation instructions for eitherWindows® operating systems orMac operating
systems software.
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Computer requirements
SMART Notebook publisher works with Adobe InDesign CS4 and CS5 on bothWindows operating
systems andMac operating system software.

Requirements for Adobe InDesign CS4

Windows operating systems
l Adobe InDesign CS4

l 20MB of free hard disk space

l Windows XP SP3, Windows Vista® orWindows 7 operating system

Mac operating system software
l Adobe InDesign CS4

l 20MB of free hard disk space

l Mac OS X operating system software 10.5.7 or 10.6.x

Requirements for Adobe InDesign CS5

Windows operating systems
l Adobe InDesign CS5

l 10MB of free hard disk space

l Windows XP SP3, Windows Vista orWindows 7 operating system

l Adobe ExtensionManager 5.0.298 or later

Mac operating system software
l Adobe InDesign CS5

l 10MB of free hard disk space

l Intel® Multicore processor

l Mac OS X operating system software 10.5.7 or 10.6.x

l Adobe ExtensionManager 5.0.298 or later
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Installing on Windows operating systems

g To install SMART Notebook Publisher for Adobe InDesign CS4

1. Go to the SMART Ecosystem Network login page, and then follow the on-screen instructions
to download the file to your desktop.

2. Double-click the .exe file.

TheSMART Notebook Publisherwizard appears.

3. Follow the on-screen instructions to complete the installation.

g To install SMART Notebook Publisher for Adobe InDesign CS5

1. Go to the SMART Ecosystem Network login page, and then follow the on-screen instructions
to download the file to your desktop.

2. Double-click the .zxp file.

The Adobe ExtensionManager appears.

3. Follow the on-screen instructions to complete the installation.

Installing on Mac operating system software

g To install SMART Notebook Publisher for Adobe InDesign CS4

1. Go to the SMART Ecosystem Network login page, and then follow the on-screen instructions
to download the file to your desktop.

2. Double-click the file.

The file contents decompress.

3. Move the file’s contents toApplications/Adobe InDesign/CS4/Plug-Ins.
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g To install SMART Notebook Publisher for Adobe InDesign CS5

1. Go to the SMART Ecosystem Network login page, and then follow the on-screen instructions
to download the file to your desktop.

2. Double-click the file.

The Adobe ExtensionManager appears.

3. Follow the on-screen instructions.
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Using SMART Notebook
publisher
Creating a new document 8
Exporting to a SMART Notebook file 9
Rendering text and image objects for export 10

Tagging objects for export 11
Exported vector text properties 12
Removing unsupported text features 13
Exported vector object properties 14

Locking content 15
Showing or hiding tags 16
Resizing to the SMART Notebook page 17

After you install the SMART Notebook publisher plug-in for Adobe InDesign, the SMART Notebook
item appears in the InDesignmenu bar. SMART designed themenu items to look and behave like
other InDesignmenu items. If you click Rendering Options, Locking orAdd Interactivity, a dock
appears containing panels that you can dock, move and hide as you can with other InDesign panels.
Using thesemenu items and panels, you can create new documents, tag text for vector or raster
export, show or hide tags and export your document to a SMART Notebook file.
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Creating a new document
When you create a new document, SMART Notebook publisher sets the document pages to
landscape orientation at 800 × 600 points so that all content on the pages is visible in a SMART
Notebook page without scrolling. This size is optimal for viewing onmost SMART Board interactive
whiteboards.

g To create a new document

1. Select SMART Notebook > File > New SMART Notebook Document.

TheNew SMART Notebook Document dialog box appears.

N   NOTES

o You can also create a new document by clicking File > New > SMART Notebook
Document.

o You can create a new document by clicking File > New > Document but it won’t be
set to landscape orientation at 800 × 600 points. SeeResizing to the SMART
Notebook page on page 17.

2. Type the number of pages you want in your document.

3. If youmake your InDesign document available to users who haven’t installed the SMART
Notebook publisher plug-in, select Enable missing plug in warning, and then click OK.

When you copy the InDesign file to a computer that doesn’t have the SMART Notebook
publisher plug-in installed, aMissing Plug-ins message appears.

I   I MPORTANT

You can’t enable or disable theEnablemissing plug-in warning option after you create the
document.

A new blank document appears.

4. Click File > Save as, type a file name for your InDesign file, and then click Save.

T   T I P

If you add background images to your document pages, lock or protect the images so that SMART
Notebook users can’t move or delete them. See Locking content on page 15 for more information.
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Exporting to a SMART Notebook file
When you’re finished your InDesign document, you can export the entire document, select pages or a
range of pages to a SMART Notebook file. You can also choose to automatically open the file in
SMART Notebook after you export it.

g To export to a SMART Notebook file

1. Select SMART Notebook > File > Export.

TheExport SMART Notebook Document dialog box appears.

2. Select the number of pages to export.

3. If you want to open the document in SMART Notebook software after you export it, select
Automatically open.

4. Click Export.

TheSave As dialog box appears.

5. Type a name in the File Name area, and then click Save.

If you selected the option in step 3, SMART Notebook software appears showing the exported
document.

N   NOTES

o You can also export your document by clicking File > Export for SMART Notebook
software.

o Your exported file can appear differently on other computers if they have a different
operating system, video resolution or screen size than your computer.
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Rendering text and image objects for export
By default, SMART Notebook publisher exports all text and image objects to SMART Notebook
software in raster format. By exporting objects in raster format, you preserve the “look and feel”of the
content when you see it on the SMART Notebook page; however, the SMART Notebook user won’t
be able to edit the content.

All objects that you tag as raster in InDesign export to SMART Notebook software as 144 dpi pixel-
based raster objects which is twice the 72 dpi resolution native to SMART Notebook software. You
can see the pixels that make up raster objects when you zoom in. Text objects aren’t recognized as
text, so you’re unable to edit them using SMART Notebook software after you export them.

You can also choose to export text or image objects to SMART Notebook software in vector format.
Text that you render in vector format in InDesign exports to SMART Notebook software as vector
text objects. SMART Notebook software recognizes these fields as text so you can edit the text and
change attributes like font, color and size. You can export any font that’s installed on your computer
as vector.

One characteristic of vector text objects is that you can resize them without compromising quality.

CHA PT ER 3

Using SMART Notebookpublisher

10



N   NOTES

l The image quality of raster formatted objects or text reduces if you change their scale.

l Many of InDesign’s text formatting properties aren’t supported by SMART Notebook
software so they don’t appear in the vector-tagged text objects on the SMART Notebook
page.

l If you want to keep the original design intact and you don’t want users to edit the content in
SMART Notebook software, use raster formatting.

Tagging objects for export
By default, SMART Notebook publisher exports all objects in raster format, preserving the image and
text objects’ properties. If you want to allow SMART Notebook users to edit the objects you can
export them in vector format, but they can lose some of their properties. SeeExported vector object
properties on page 14 andExported vector text properties on next page for more information.

g To tag objects for vector export

1. Select a text or image object.

2. If the dock isn’t open, select SMART Notebook > Rendering Options.

3. Select Export as vector .

The vector tag appears on the bottom-right corner of the object.

g To tag objects for raster export

1. Select a text or image object.

2. If the dock isn’t open, select SMART Notebook > Rendering Options.

3. Select Export as raster.

The vector tag clears from the object.
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Exported vector text properties

I   I MPORTANT

If you export text in vector format, it might not appear the same on a SMART Notebook page
because of the different formatting options available in SMART Notebook software, such as
character spacing, leading indents and bullet types.

You can export text in vector format using any font installed on your computer. Use common fonts
because you’re unable to embed fonts in SMART Notebook software.

You can export text objects in vector format with the following formatting properties:

l Font size and color l Bold, italics and underline l Bullets

l Transparency l Left and right justification

The following are examples of effects and formatting that aren’t supported and are removed when you
export text objects in vector format. SeeRemoving unsupported text features on next page to remove
these unsupported effects before you export the document.

l Kerning l Tracking l Case (e.g., small caps)

l Position l Strikethrough l Ligatures

l Scale l Baseline shift l Skew

l Indents and spacing l Underline l Color options

l Drop caps

N   NOTES

l SMART recommends that you use text boxes without lines or fill.

l If you export bullets in vector format, they don’t always behave as expected.

l Shaped objects containing text aren’t supported.

l Frames within frames aren’t supported.
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Removing unsupported text features
If your InDesign document has text effects or paragraph styles that aren’t supported in SMART
Notebook software, you can remove them and preview what the exported file looks like by using the
Removing unsupported text features option. See To remove unsupported text features on next page.

EXAMPLE

If you have a text object with a drop shadow, selecting the option tags the object for vector export
and removes the effect as shown below.

Raster text object with
drop shadow effect

Unsupported text features
removed

Text object seen on
SMART Notebook page

Export

EXAMPLE

If InDesign has automatically inserted hyphens in a text object, selecting the option tags the object
for vector export and removes the hyphens as shown below.

Raster text object with
auto-inserted hyphens

Unsupported
hyphens removed

Text object seen on
SMART Notebook page

Export

N   NOTES

l You can retain text effects by exporting the text object in raster format.

l If you tag a text object for vector export, but don’t remove the unsupported text features, you
won’t be able to preview the text in InDesign.

CHA PT ER 3

Using SMART Notebookpublisher

13



g To remove unsupported text features

1. Select the text object.

2. If the dock isn’t open, select SMART Notebook > Rendering Options.

3. Select Remove unsupported text features.

The unsupported text features are removed, and the vector tag appears on the bottom-right

corner of the object.

N   NOTE

Repeat the procedure if you add features to your text object after you initially perform this
procedure..

Exported vector object properties
SMART Notebook software interprets lines exported in vector format as digital ink and converts
shapes into shapes you can edit.

The following are examples of formatting that isn’t supported by SMART Notebook publisher when
you export objects in vector format.

l Shapes with gradient fill

l Text within objects

l Frames within frames

l Compound paths

If you export on a SMART Notebook page, they appear as

straight lines straight lines

curved or multi-point lines digital ink

closed objects closed shapes that you can fill

circles and ellipses polygon shapes

N   NOTE

If you have compound paths in your document, click Object > Paths > Release Compound Path
on the InDesignmenu bar to make them compatible with SMART Notebook software. Youmight
have to do this several times.
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Locking content
When you create new content, text and image objects are unlocked by default.

N   NOTES

l When you lock an object, it’s locked on a SMART Notebook page only. It isn’t locked on your
InDesign page.

l After you export the document, SMART Notebook users can unlock objects, but they can’t
unprotect an object.

There are five options for locking objects:

Option Description

Unlock You canmove, rotate and edit the object

Lock in place You can’t move, rotate or edit the object

Allow move You canmove the object, but you can’t rotate or edit it

Allow move and rotate You canmove or rotate the object, but you can’t edit it

Protect You can’t move, rotate, edit or unprotect the object

N   NOTES

l If users want to copy or paste objects in SMART Notebook software, they can unlock them.
They can’t remove protection from an object, so they can’t copy or paste protected objects.

l Protect content such as copyrighted images when you want to be sure that users can’t
unlock it.

l SMART Notebook software puts protected content into the bottom layer of the SMART
Notebook page where users can’t unlock it.

g To lock or protect objects

1. Select the text or image object.

2. Select SMART Notebook > Object Attributes.
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3. Select one of the options under the Locking heading.

A tag indicating the option you selected appears at the edge of the object. If you selected
Protect, the object also has a cross-hatch shading over it, as shown below.

N   NOTE

TheShow/Hide Tags feature also removes the cross hatch shading from protected objects.
SeeShowing or hiding tags below.

Showing or hiding tags
Depending on whether you tag a single object or a grouped object, theRendering, Locking or
Interactivity tags appear below or beside the object or objects.

EXAMPLE

Single object Grouped object

If the tags obscure other objects on your page, you can hide them. To show them again, repeat the
procedure below.

N   NOTE

If you put InDesign into Overprint Preview mode, all SMART Notebook publisher tags are hidden.
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g To show or hide tags

Select SMART Notebook > Show/Hide Tags, and then select or clear the option.

N   NOTE

If there’s a check mark beside the tag type in themenu, tags are showing.

Resizing to the SMART Notebook page
When you create a new document using the procedure inCreating a new document on page 8,
SMART Notebook publisher sets the pages to landscape orientation at 800 × 600 points so that all
content on the pages is visible in a SMART Notebook page without scrolling.

If you import an InDesign file or create a new one (using File > Newmenu in InDesign) with different
dimensions or in portrait orientation, the exported file doesn’t fit the SMART Notebook page.

You can use theResize to SMART Notebook Page feature to change your document’s orientation to
landscape and resize it to 800 × 600 points.

N   NOTES

l If your page is more than 800 points wide, content on the page is cropped from the SMART
Notebook page.

l If your page is more than 600 points long, the SMART Notebook page extends so that users
must use a scroll bar to see all of the page.

g To resize your InDesign page

1. Select SMART Notebook > Document Setup > Resize to SMART Notebook Page.

A SMART Notebook publisher dialog box appears stating that the document will resize to 800
× 600 points, and that some objects could fall outside of the viewable area.

Select theDon’t show again option if you don’t want to see this dialog box again.

2. Click OK.
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Adding interactive effects
Creating SMART hyperlinks 19
Using Erase to Reveal 20
Alternative Erase to Reveal 22
Using the Infinite Cloner 23
Adding sound effects 24
Animating objects 25

You can add one or more interactive effects to the objects on your document pages. You can also
modify or remove all of these effects after you export your document to SMART Notebook software.

Creating SMART hyperlinks
You can add hyperlinks to objects that link to another page in your document or to a web page. You
can also choose to use the object or an icon on the corner of the object to open the link.

g To add a hyperlink

1. Select the text or image object.

2. If the dock isn’t open, select SMART Notebook > Add Interactivity.

3. Select SMART Hyperlink .

4. Select a destination type from the Location drop-down list.

The Launch by clicking options appear.
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5. If you select Page in this file, select the page number from the drop-down list.

If you selectWeb page, type the URL in the text field.

A Page in this file orWeb page tag appears at the edge of your InDesign object.

N   NOTE

A red tag on your InDesign object indicates that you didn’t select a page or the link is
missing.

6. If you want to add the hyperlink to the entire object, select Object in the Launch by clicking
area.

If you want to add the hyperlink to an icon on the lower-left corner of the object on the SMART
 Notebook page, as shown below, select Corner icon.

N   NOTE

SMART Notebook users won’t know that there’s a link on an object unless you tell them or
select Corner icon.

g To remove a hyperlink

1. Select the object.

2. If the dock isn’t open, select SMART Notebook > Add Interactivity.

3. Select SMART Hyperlink .

4. Select None from the Location drop-down list.

Using Erase to Reveal
You can hide content with a rectangular color fill that you can later reveal by erasing in SMART
Notebook software. The Erase to Reveal feature hides the entire object, so if you want to hide a
portion of an object, or use an irregularly shapedmask to hide an object, seeAlternative Erase to
Reveal on page 22.
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g To enable Erase to Reveal

1. Select the text or image object.

2. If the dock isn’t open, select SMART Notebook > Add Interactivity.

3. Select Erase To Reveal .

4. Select a color from the Ink color drop-down list.

T   T I P

o The colors shown in the list are the same as the colors in the InDesignSwatch list.

o Use only solid colors. SMART Notebook publisher doesn’t support gradient fills.

o If you want the objects to be invisible until you reveal them, select the same color as
the page’s background color.

o If you want it to be obvious that ink is covering an object, select a color that contrasts
the background color.

A green eraser tag appears below the object, and a small rectangle showing the selected color
appears on the lower-right corner of the object.

After you save and export the document to SMART Notebook software, a colored rectangular mask
hides the object. The rectangle is four points larger, with four point radius corners, than the object.
You can use the eraser in SMART Notebook software to erase the coloredmask, revealing the
object.

EXAMPLE

InDesign object
SMART Notebook

object hidden
SMART Notebook

object partially revealed

Export as
.notebook

file

Erase the
mask
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Alternative Erase to Reveal
You can create your own “Erase to Reveal” effect to hide a portion of an object or an irregularly
shaped object by creating your ownmasking shape.

g To hide an object

1. Draw a thick line with more than two points using InDesign drawing tools to create a shape
slightly larger than the object you want to hide.

2. Change the shape’s color as required.

T   T I P

If you want the objects to be invisible until you reveal them, select the same color as the
page’s background.

3. Drag the shape over the object you want to hide.

4. Select the shape.

If the dock isn’t open, select SMART Notebook > Rendering Options.

5. Select Export as vector .

The vector tag appears on the bottom-right corner of the object.

After you save and export the document to SMART Notebook software, a coloredmask hides the
object. You can use the eraser in SMART Notebook software to erase the coloredmask, revealing
the object.

EXAMPLE

InDesign object
with mask

Mask changed
to white and
tagged for
vector

SMART
Notebook

masked object

Mask partially
erased

Export Erase
mask
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Using the Infinite Cloner
By enabling the Infinite Cloner, you can quickly duplicate text or image objects after you export them
to SMART Notebook software.

N   NOTE

Don’t enable the Infinite Cloner on objects that have interactive effects such as animation or links.

g To enable the Infinite Cloner

1. Select the text or image object.

2. If the dock isn’t open, select SMART Notebook > Add Interactivity.

3. Select Infinite Cloner .

4. Select the Infinite Cloner check box.

A green Infinite Cloner tag appears below the object.

After you save and export the document to SMART Notebook software, you can drag the
object to create copies.

EXAMPLE

InDesign
object

SMART
Notebook
object

SMART Notebook
object cloned

Export as a
.notebook file

Drag
object

For more information on using the Infinite Cloner feature in SMART Notebook software, click the
SMART Board icon in theWindows notification area or Mac dock, select Help and then search
for Infinite Cloner.
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Adding sound effects
You can add links from objects to MP3 sound effects files that open when you select the object. You
can also choose to use the object or an icon at the corner of the object to open the sound file.

N   NOTES

l The linkedMP3 file isn’t packaged in the InDesign file, but it is embedded in the exported
SMART Notebook file.

l LargeMP3 files can affect the performance of the SMART Notebook page.

g To add a sound effect to an object

1. Select the text or image object.

2. If the dock isn’t open, select SMART Notebook > Add Interactivity.

3. Select Sound Effect .

4. Select theAdd sound check box.

The File box and the Launch by clicking options appear, and a tag appears at the edge of

your InDesign object.

N   NOTE

A red tag on your InDesign object indicates that you didn’t select a sound file or the link is
broken.

5. Click Browse and locate theMP3 sound file you want to link to the object.

6. If you want to link theMP3 file to the entire object, select Object in the Launch by clicking area.

If you want to link theMP3 file to a speaker icon on the lower-left corner of the object, as shown
below, select Corner icon.

N   NOTE

Users won’t know that there is a sound effect on an object unless you tell them, or select
Corner icon.
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Animating objects
You can tag text or image objects for animation in a variety of ways:

l Fade in or out

l Flip around axis

l Fly in or out

l Shrink and grow

l Spin

The options you can use to set the direction, speed, start and repetition vary depending on the
animation type you select.

I   I MPORTANT

You are unable to see or demonstrate the animation on your InDesign page. The animation is visible
only on your SMART Notebook page after you export it.

g To animate an object

1. Select the text or image object.

2. If the dock isn’t open, select SMART Notebook > Add Interactivity.

3. Select Animation .

4. Select an option from the Type drop-down list.

A green tag appears at the edge of the object, as shown below.
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5. Select the characteristics of the animation from theDirection, Speed, Occurs andRepeats
drop-down lists.

N   NOTE

The options available change depending on the animation type selected.

After you save and export the document to a SMART Notebook file, you can use SMART
Notebook software to change the animation properties .
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Troubleshooting
Troubleshooting InDesign issues 28
Troubleshooting export issues 29

This section includes information on how to troubleshoot common problems you could encounter
when using the SMART Notebook publisher plug-in for InDesign.
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Troubleshooting InDesign issues
Issue Cause Solution

When you install the SMART
 Notebook publisher plug-in for
InDesign CS5 forWindows
computers, a "cannot be
verified" error message appears.

A certificate authority issuer is
missing from the Certificate
manager Trusted Root
Certification Authorities
folder on the computer.

Follow the instructions on
/www.globalsign.com/support
/root-certificate/osroot.php to
download and install the
GlobalSign Root CA certificate.

When you undo changes to an
object’s sound, animation or
Erase to Reveal features while
the object is selected, the object
shows that the changes are
reversed, but the panels don’t
update to show the changes.

Clear and then select the object
to refresh the panel, showing
the changes

When you assign a gradient
color swatch, an error and a
white Erase to Reveal object
appears.

Notebook publisher software
doesn’t support gradient color.

When you use InDesign CS5 on
aMac computer, the SMART
 Notebook publisher panels
behave unexpectedly.

This is a known Adobe
InDesign issue.

When you stack the SMART
 Notebook publisher panels and
select a lower one to bring to the
front, it behaves unexpectedly.

This is a known Adobe
InDesign issue.

Resize the panel to refresh it.

When you use InDesign CS5 on
aMac computer, youmust
select controls, such as Infinite
Cloner, twice to activate them.

This is a known Adobe
InDesign issue.
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Troubleshooting export issues
This section provides information to help you troubleshoot issues you encounter when exporting your
InDesign pages to SMART Notebook software.

Issue Cause Solution

The color of text exported in
vector format appears differently
on a SMART Notebook page.

SMART Notebook publisher
uses Adobe InDesign Color
Management System to
convert CMYK color to RGB
when it saves the file as a
.notebook file.

Use RGB colors when creating
your InDesign document.

OnMac computers, object lines
exported in vector format don’t
appear on a SMART Notebook
page.

SMART Notebook software
doesn’t support a line thickness
of less than one pixel.

Use a line thickness greater
than one pixel when creating
your InDesign document.

A sound file linked to an object
on an InDesign page doesn’t
play in SMART Notebook
software on a different computer.

The InDesign Package feature
doesn’t include the sound
file.The sound file must be on
the computer with SMART
 Notebook software at the same
location as the computer with
InDesign.

Copy the sound file to the same
location on the computer with
SMART Notebook software.

Gradient fills, compound shapes
and special effects on objects
exported in vector format don’t
appear correctly on a SMART
 Notebook page.

SMART Notebook software
doesn’t support these InDesign
features

Refer to
(smarttech.com/kb/158137).

Objects and text rotated using
the InDesign Rotate Spread
feature don’t appear correctly on
a SMART Notebook page.

SMART Notebook publisher
doesn’t support the Rotate
Spread feature.
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